Article ID: 125761, created on Jun 5, 2015, last review on Jun 5, 2015

  • Applies to:
  • Operations Automation 6.0
  • Operations Automation 5.5
  • Operations Automation 5.4

Question

You as Provider want to use multiple PHP versions for Linux Hosting NG. How it can be achieved?

Answer

POA 5.4 and below can work only with 1 version of PHP. Yoг need to upgrade to POA 5.5 and enable "Alt-PHP" as per the following documentation.

The next step is to update the information about the PHP installed on the NG web cluster:

  1. Switch to the 'Apache Extensions' tab in the NG web cluster properties.
  2. Click the 'Synchronize Apache Extensions' button.
  3. Wait until the background task with the 'Update list of Apache service extensions for service with ID #ID' name is completed in the POA Task Manager.

Also make sure that path to php binary on hardware node (NG server) and 'Path to php binary' in the PHP resource activation parameters are the same.

Example: Path to php binary on hardware node (NG server) is /opt/alt/php54/usr/bin/php-cgi. The same path should be in the PHP resource activation parameters. If the path is not same, please do the following:

  1. Go to POA Provider CP Top > Products > Service Templates > > 'Resource' tab > > 'Activation Parameters'.
  2. Click 'Edit -> Path to php binary'. Set the correct path as on the hardware node.
  3. Then sync Apache extensions on POA Provider CP from 'Top > Infrastructure > Hardware Nodes > 'Web Clusters' tab > Apache extensions page'.

Search Words

multiple PHP versions

up grade PHP

ac82ce33439a9c1feec4ff4f2f638899 caea8340e2d186a540518d08602aa065 e12cea1d47a3125d335d68e6d4e15e07 5356b422f65bdad1c3e9edca5d74a1ae 2554725ed606193dd9bbce21365bed4e 956c448bddc7e1f3585373687602379f 6f1456866eed87488c0f02b298a741c0 5b048d9bddf8048a00aba7e0bdadef37

Email subscription for changes to this article
Save as PDF