Article ID: 125680, created on May 31, 2015, last review on Nov 22, 2015

  • Applies to:
  • Plesk Automation 11.5

Symptoms

  1. Plesk Automation(PA) is behind NAT and 203.0.113.2 is external IP, 192.0.2.2 - the IP Address on the local interface

  2. PA installation fails with error:

    The hostname 'hostname.example.com' points to non-existent IP '203.0.113.2'. It should point to IP address: 192.0.2.2
    
  3. Update installation fails with error:

    # /usr/local/ppa/bin/ppa_update --install-updates
    ...
    [ERROR]:
    Checking hostname of hosts registered in PPA has failed.
    Check the following hosts:
            * host 'hostname.example.com' (11) hostname check failed: The hostname 'hostname.example.com' points to non-existent IP '203.0.113.2'. Please correct the hostname.
    
  4. File /etc/hosts on PA Management node is configured to resolve hostname.example.com into its external IP addresses.

Cause

The issue could occur in case of using NAT address translation. Server hostname is resolved to the Public IP address which is not assigned on the local network interface.

Resolution

Add local IP address for hostname.example.com in the /etc/hosts file on PA Management node. For example:

192.0.2.2 hostname.example.com

If you will face this issue again also add the same record in the /etc/hosts on hostname.example.com service node and rerun update.

Search Words

hostname check failed

points to non-existent IP

points to non-existent ip

remove ip from service node

Update installation fails

The hostname points to non-existent IP

Checking hostname of hosts registered in PPA has failed.

Installation fails

Please correct the hostname.

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