Article ID: 125551, created on May 18, 2015, last review on Aug 23, 2015

  • Applies to:
  • Operations Automation 5.5
  • Operations Automation 5.4

Symptoms

Webalizer Default page is displayed instead of the web statistics of a particular Apache website.

Cause

The issue may be caused by an missing entry for the domain in logparser configuration file /usr/local/pem/etc/logparser/config.xml, also the file might be corrupted.

Resolution

  1. Find out the service ID of logparser for the host is question under the Infrastructure > Services.
  2. Run an internal pem.syncServiceConfiguration OpenAPi call:

    <?xml version='1.0'?><methodCall>
    <methodName>pem.syncServiceConfiguration</methodName>
    <params>
    <param>
    <value>
    <struct>
    <member>
    <name>service_id</name>
    <value><i4>97</i4></value> ##Put the respective Service ID here
    </member>
    </struct>
    </value>
    </param>
    </params>
    </methodCall>
    
  3. Put the appropiate values in the command and execute:

    webalizer -p -N 5 -o /usr/local/pem/vhosts/<webspace ID>/webspace/webstat -n <hostname> -c /usr/local/pem/vhosts/<webspace ID>/webspace/conf/webalizer.conf /usr/local/pem/vhosts/<webspace ID>/log/access_log
    

to regenerate missing statistics right away.

Search Words

на этом сервере в файле config.xml наш вебспейс отсутсвует

AWStats Web Statistics

webalizer config.xml

No Webalizer stats available on site

webalizer

webalizer missing statistics logrotate

5356b422f65bdad1c3e9edca5d74a1ae caea8340e2d186a540518d08602aa065 e12cea1d47a3125d335d68e6d4e15e07 5b048d9bddf8048a00aba7e0bdadef37 2554725ed606193dd9bbce21365bed4e ac82ce33439a9c1feec4ff4f2f638899

Email subscription for changes to this article
Save as PDF