Article ID: 125391, created on May 1, 2015, last review on May 1, 2015

  • Applies to:
  • Operations Automation 5.5

Symptoms

The following task fails:

Task name   Install set of VZ templates to VPS vps
Task description    Install of following VZ templates into VPS: .pp12-msmtp.centos-6-x86_64/, .pp12-bind.centos-6-x86_64/, .pp12-mailman.centos-6-x86_64/, .pp12-php5.centos-6-x86_64/, .pp12-webhosting-addons.centos-6-x86_64/, .pp12.centos-6-x86_64/, .pp12-postfix.centos-6-x86_64/, .pp12-courier-imap.centos-6-x86_64/, .pp12-migration.centos-6-x86_64/, .pp12-panel-addons.centos-6-x86_64/, .pp12-spamassassin.centos-6-x86_64/, .pp12-watchdog.centos-6-x86_64/, .pp12-webmail.centos-6-x86_64/

Last execution output   
Internal error: 3501 : Can not install packages: ' vzpkg install -q 10205 .pp12-bind .pp12 .pp12-courier-imap .pp12-mailman .pp12-migration .pp12-msmtp .pp12-panel-addons .pp12-php5 .pp12-postfix .pp12-spamassassin .pp12-watchdog .pp12-webhosting-addons .pp12-webmail' exec failed - Error: plesk-mail-mc-driver conflicts with postfix
Error: plesk-mail-mc-driver conflicts with psa-courier-imap
Error: plesk-mail-mc-driver conflicts with plesk-courier-imap-driver
Error: plesk-mail-pc-driver conflicts with sw-msmtp
Error: plesk-mail-mc-driver conflicts with psa-courier-authlib
Error: plesk-mail-mc-driver conflicts with psa-mail-driver-common
Error: /usr/share/vzyum/bin/yum failed, exitcode=1

Cause

Provider has configured service template to install both pp12-postfix and pp12-msmtp application templates automatically during subscription creation.

These 2 application templates are mutually exclusive and cannot be used at same time.

Resolution

Open service template > Application templates and make sure only one of these 2 application templates is marked as "Install automatically"

For already existing failed tasks - cancel task and fix the templates via following way:

  1. From POA PCP go to "Cloud Infrastructure > VPSs" and select the needed VPS.
  2. Click on the "Application templates" tab, then click on the needed template in "Installation Failed" state.
  3. In the opened tab, click on the template name again, then switch to the "VPSs" tab, select the needed VPS and click "Uninstall". This should be done for every template in "Installation Failed" state.

Search Words

plesk-mail-mc-driver conflicts with postfix

5356b422f65bdad1c3e9edca5d74a1ae caea8340e2d186a540518d08602aa065 e12cea1d47a3125d335d68e6d4e15e07 5b048d9bddf8048a00aba7e0bdadef37 2554725ed606193dd9bbce21365bed4e

Email subscription for changes to this article
Save as PDF