Article ID: 124832, created on Mar 12, 2015, last review on Mar 12, 2015

  • Applies to:
  • Business Automation 6.0

Symptoms

When the steps below are followed:

  1. Home -> Operations -> Subscriptions -> subscriptionID
  2. Click on Service Plan ID on the General page
  3. Click on "Subscription Periods" tab or "Resource Rates" tab.

an error occurs:

Table Service Plan doesn't contain row with id Int32(NULL).

Cause

This issue is caused by product bug with id #PBA-62342.

Resolution

As a workaround perform the following steps:

  1. Create file /usr/local/bm/customization/Plan_MyPlanList.xml

    with the following content

    <window id="Plan_MyPlanList">
    <actions>
        <action id="StandardInput">
          <call type="server" callee=BM::GetMyServicePlans(sortno) return=PlanID, name/>
          <call type="server" callee=BM::GetCurrentAccountID() return=AccountID />
        </action>
    </actions>      
    </window>
    
  2. Restart WWW container:

    /etc/init.d/www restart

    You will need to remove the customization file after update with bug fix is installed.

Search Words

Table Service Plan doesn't contain row with id Int32(NULL).

198398b282069eaf2d94a6af87dcb3ff caea8340e2d186a540518d08602aa065 e12cea1d47a3125d335d68e6d4e15e07 3627d36199b8ff577605df76e2fa222b bb7e9177fb03488961a3ea554120f328

Email subscription for changes to this article
Save as PDF