Article ID: 124497, created on Feb 19, 2015, last review on Sep 16, 2016

  • Applies to:
  • H-Sphere 3.6.3

Symptoms

Logical Web Server can not be deleted because IP address is used however no users are on the server.

Cause

Database inconsistency.

Resolution

NOTE: Before applying DB changes please take a backup.

  1. Log into H-sphere Database under cpanel user

    #su -l cpanel
    #psql hsphere
    
  2. Find IP address of the affected server:

    hsphere=# select * from l_server_ips where ip = '<ip_address_server>';
     l_server_id |      ip      |   ip_num   |     mask      | flag | r_id | r_type
    -------------+--------------+------------+---------------+------+------+--------
              24 | 10.10.10.10  | 3507021880 | 255.255.255.0 |    1 | 4940 |      8
    (1 row)
    
  3. Check if resource with 'r_id' from output above exist in "parent_child" table.

    hsphere=# select * from parent_child where child_id = 4940;
     parent_id | parent_type | child_id | child_type | account_id | p_begin | suspended
    -----------+-------------+----------+------------+------------+---------+-----------
    (0 rows)
    
  4. If output is "0 rows" you can safely delete the record from 'l_server_ips' table.

    hsphere=# delete from l_server_ips where ip = '10.10.10.10';
    DELETE 1
    

Search Words

You should delete all IPs before removing Logical server

Busy Dedicated IP

6b908665c0d1eca5bdd0141a32fd712a 6311ae17c1ee52b36e68aaf4ad066387 f213b9fa8759d57bee5d547445806fe7 2e39a5e5b1423cc126cf735bac076008

Email subscription for changes to this article
Save as PDF