Article ID: 124479, created on Feb 16, 2015, last review on Dec 28, 2015

  • Applies to:
  • Operations Automation
  • Business Automation

Release Notes

Dependencies and Pre-Requisites

The Hosted BroadWorks Application Package requires:

  • OA 5.5.8 or higher
  • BA 5.4.4 or higher
  • BroadSoft BroadWorks version 20 SP1 or higher (it is also recommended to install "Patch 238459: Padding Oracle On Downgraded Legacy Encryption (POODLE) SSLv3 protocol vulnerability - CVE-2014-3566")

New Features and Capabilities

Ability to Hide ESBC Settings in CCP Is Implemented

The new property ESBC Supported is added into the “Phone” application service. This property allows a provider to control the availability of the ESBC settings in Customer Control Panel. If set to Yes, the ESBC settings become visible in CCP; if set to No, the settings disappear from CCP. The default value of the ESBC Supported property is “No”.

After the upgrade, this property will be set to the “No” value and ESBC settings will disappear from all the provisioned phone devices.

Fixed Issues

APSA-9730 All resources for country-specific locales (en-US, es-ES) on external site of the Web-based management service must have a default "language-only" version (en, es) for fallback purposes.

APSA-9567 Invalid error message is shown in CCP if a device's MAC address is not unique

APSA-9703 Not understandable error message when trying to assign another Receptionist to the same PBX user

APSA-9642 Not localized values Allow/Block when creating user with Calling Plans Override

APSA-9599 There is no ability to hide E-SBC configuration in CCP

APSA-10269 Office Communicator Tab: Service is not licensed

Obtaining

To obtain the current version or updates of the Hosted BroadWorks Application Package, contact your Odin representative.

Installation

To install the Hosted BroadWorks Application, use the instructions provided in the PA BroadWorks Integration Provider's Guide.

Upgrade Procedure

Important:
Make sure the source version of the Hosted BroadWorks Application is 4.0. Upgrades from other versions are not allowed.

The upgrade procedure consists of the following steps:

  1. Installing .NET 4.5 on Provisioning Gateway host and Web-based Management host.
  2. Upgrading the Web-based Management Service.
  3. Upgrading the Hosted BroadWorks Application.
  4. Performing additional upgrade steps.

Important:

  1. The upgrade procedure is not reversible.
  2. All these upgrade steps are mandatory.

To upgrade an existing installation of the Hosted BroadWorks Application, perform the following actions:

  1. Install .NET 4.5 on Provisioning Gateway host and Web-based Management host.
  2. Upgrade the Web-based Management Service:

    1. Place the HostedBroadWorks.Web.Install.exe file on the host running the Web-based Management Service.
    2. Run the HostedBroadWorks.Web.Install.exe file and follow the Wizard.
    3. Complete passing the Wizard.

  3. Upgrade the Hosted BroadWorks Application:

    1. Import the Hosted BroadWorks Application Package to PA. See OA Provider's Guide >> Application Hosting > Managing Applications > Importing Application for details.
    2. Upgrade existing Hosted BroadWorks Application instances. See OA Provider's Guide >> Application Hosting > Bulk Application Upgrades for details.

  4. After the upgrade, the default value of the ESBC Supported property in the "Phone" Resource Types will be set to “No”, thus the settings of the E-SBC will disappear in customer control panel. If you need to switch it back on, go to the necessary Resource Type and manually set the ESBC Supported property to "Yes".
  5. Help Resources

    PA BroadWorks Integration Guides are available here: http://download.pa.parallels.com/poa/.

    All BroadWorks Integration Release Notes

198398b282069eaf2d94a6af87dcb3ff caea8340e2d186a540518d08602aa065 e12cea1d47a3125d335d68e6d4e15e07 5356b422f65bdad1c3e9edca5d74a1ae

Email subscription for changes to this article
Save as PDF