Article ID: 124315, created on Jan 28, 2015, last review on Jan 28, 2015

  • Applies to:
  • H-Sphere

Situation

During a code audit performed internally at Qualys a heap-based buffer overflow was found in glibc's "__nss_hostname_digits_dots()" function, which is used by the gethostbyname() and gethostbyname2() glibc function calls.

Impact

There is a remote code execution risk due to this vulnerability. An attacker who exploits this issue can gain complete control of the compromised system.

More information about CVE-2015-0235 can be found in Qualys Blog and on Openwall website.

Call to Action

  1. To close the vulnerability, install the latest available version of glibc from the OS vendor repository.

    # yum update glibc
    
  2. Restart network services having external access (for example Apache, SSH, MySQL)

Parallels takes the security of our customers very seriously and encourages you to take the recommended actions as soon as possible.

We also strongly encourage you to stay connected to Parallels for important product-related information via these methods:

Search Words

CVE-2015-0235

Security Advisory

glibc

f213b9fa8759d57bee5d547445806fe7 6311ae17c1ee52b36e68aaf4ad066387

Email subscription for changes to this article
Save as PDF