Article ID: 124266, created on Jan 23, 2015, last review on Sep 15, 2016

  • Applies to:
  • Plesk Automation

Symptoms

Unable to install application because of error:

Unable to install the app because its installation requirements are not met. Contact your hosting provider to resolve this problem. 
The app requires the mysql database server version 5.1 or later.

or:

Unable to install the app because its installation requirements are not met. Contact your hosting provider to resolve this problem. 
    The app requires the mysql database server version 5.5 or later.

Cause

  1. MySQL server is not configured for subscription.

  2. MySQL version is lower than 5.1 or 5.5

  3. Not completed tasks for subscription in Task Manager.

Resolution

  1. By default Plesk Automation (PA) has Default MySQL Server and if there are other registered MySQL Servers in Hosting Provider CP > Database Servers, you may specify which MySQL server should be used for subscription by default. For that the following command should be executed on Management Node:

    # /usr/local/psa/bin/subscription_settings -u <subscription_main_domain_name> -default_server_mysql <MySQL_server_ip_address>:3306
    
  2. Make sure that MySQL version is correct (for example if version 5.1 is needed for application):

    # mysql -V
    mysql  Ver 14.14 Distrib 5.1.69,
    
    # rpm -qa | grep mysql
    mysql-5.1.69-1.el6_4.x86_64
    mysql-server-5.1.69-1.el6_4.x86_64
    
  3. Check and complete all tasks for subscription that you install the application under Hosting Provider CP > Task Manager.

  4. To resolve the issue with MySQL 5.5 please add MySQL 5.5 database server service node. Since update 18 Plesk Automation supports new role "MySQL 5.5 database server", so you can add new service node with MySQL 5.5. This scenario is more safe as there is no risk to run into a problem with packet dependencies or database corruption.

Search Words

unable to install application

installation requirements are not met

Impossibile installare l'applicazione perché i requisiti dell'installazione non sono stati soddisfatti. Contatta il tuo provider di hosting per risolvere questo problema.

installing Wordpress mysql5 not installed

Wordpress install from plesk results in features not found

The app requires the mysql database server version 5.5 or later

The app requires the mysql database server version 5.1 or later

e0aff7830fa22f92062ee4db78133079 caea8340e2d186a540518d08602aa065

Email subscription for changes to this article
Save as PDF