Article ID: 124211, created on Jan 17, 2015, last review on Feb 13, 2015

  • Applies to:
  • Operations Automation 5.5

Symptoms

Sites randomly produce error 500 with this error in the /var/www/vhosts/MNT_POINT/WEBSPACE_ID/log/error_log:

[Thu Dec 17 20:44:59 2014] [error] Error on lve_setup_enter -34 LVE id 152802

/var/log/messages get filled with errors like:

Dec 17 22:32:04 NG-web03 kernel: [90149.763736] LVE: [558776] lve_check_limits: invalid iops limit -2054380720

Checking LVE limits in POA and Redis shows that it is enough to work stable.

After the first request to website LVE sets unreal IOPS value:

[root@web01 ~]# lvectl limits 152802
      ID   SPEED    NCPU    PMEM    VMEM      EP   NPROC      IO    IOPS
  152802     240       4      0K      0K     200     200  1024001837092528

Cause

The issue is caused by these CloudLinux packages:

[root@ng03 ~]# rpm -q lve liblve liblve-devel
lve-1.3-1.3.el6.cloudlinux.x86_64
liblve-1.3-1.3.el6.cloudlinux.x86_64
package liblve-devel is not installed

It was found in versions (1.3-1.3) and was fixed in a new version 1.3.5.

Resolution

Cloudlinux team have provided patched LVE libraries. Please run this command to install them:

# yum update lve liblve liblve-devel --enablerepo=cloudlinux-updates-testing

Note: Omit liblve-devel if it is not installed on your server.

After installation the following commands should be run:

# echo "Y" > /sys/module/lve/parameters/lve_user_setup
# /etc/init.d/httpd restart

Search Words

Error on LVE enter -34 LVE id <webspace>

lve_check_limits: invalid iops limit

5b048d9bddf8048a00aba7e0bdadef37 caea8340e2d186a540518d08602aa065 e12cea1d47a3125d335d68e6d4e15e07 5356b422f65bdad1c3e9edca5d74a1ae 2554725ed606193dd9bbce21365bed4e

Email subscription for changes to this article
Save as PDF