Article ID: 124123, created on Jan 1, 2015, last review on Jan 1, 2015

  • Applies to:
  • Operations Automation 5.5
  • Operations Automation 5.4
  • Operations Automation 5.0

Symptoms

Tasks for upgrading mediawiki APS fail with the error:

Script execution failed: executing '/usr/bin/php-cgi -d open_basedir= -q configure' for APS application instance with id 1909 returned value '1' with output 'MediaWiki 1.22.2 Updater PCRE 7.2 or later is required. Your PHP binary is linked with PCRE 4.5.

Cause

Old version of PCRE is installed on the web server where APS instance is installed:

# rpm -qa |grep pcr
pcre-4.5-3.2.RHEL4
pcre-devel-4.5-3.2.RHEL4 

Resolution

To fix the error, please download the required version of PCRE and install it:

# rpm -Uvh --test pcre-7.6-1.x86_64.rpm
Preparing...                ########################################### [100%]
# rpm -Uvh pcre-7.6-1.x86_64.rpm
Preparing...                ########################################### [100%]
1:pcre                   ########################################### [100%]
# rpm -qa | grep pcre
pcre-7.6-1

After that resubmit the failed task, it should be processed successfully.

Search Words

Your PHP binary is linked with PCRE

Fatal exception of type MWException.

APS application mediawiki upgrade failed

pcre resource

c27596ac4fff6cb4c8ec8891dae57001 caea8340e2d186a540518d08602aa065 e12cea1d47a3125d335d68e6d4e15e07 5356b422f65bdad1c3e9edca5d74a1ae 2554725ed606193dd9bbce21365bed4e ac82ce33439a9c1feec4ff4f2f638899 5b048d9bddf8048a00aba7e0bdadef37

Email subscription for changes to this article
Save as PDF