Article ID: 123492, created on Nov 12, 2014, last review on May 16, 2016

  • Applies to:
  • Plesk Automation 11.5

Symptoms

The task Create the webspace with ID 7 in the Hosting Panel fails with the following error:

Owner with external ID = '209' does not exist in Plesk database

Cause

This account has already been created, but was later removed. However, the task to remove the account failed and was subsequently canceled.

Resolution

Find the account login name in the Users menu in Plesk Automation (PA) control panel, using the ID mentioned in the error message. Then, update the database using the following steps:

  1. Create a database dump as described in "How to create backups of Plesk Automation databases"

  2. Log into the psa database:

    mysql -uadmin -p`cat /etc/psa/.psa.shadow` psa 
    
  3. Find the relevant account in the 'psa' database:

    mysql> select * from clients where login='user'\G
    
  4. Update the account with the required external_id and other information (if necessary)

    mysql> update clients set external_id=209 where login='user';
    

    NOTE: login name should be specified in the task's parameter, below the error. If the query above does not update anything, contact Odin Technical Support.

33a70544d00d562bbc5b17762c4ed2b3 caea8340e2d186a540518d08602aa065 e0aff7830fa22f92062ee4db78133079

Email subscription for changes to this article
Save as PDF