Article ID: 123489, created on Nov 12, 2014, last review on Nov 12, 2014

  • Applies to:
  • Business Automation 5.5

Symptoms

On accessing Online Store (provider's or resellers) nothing is displayed in browser. In the Online Store container the following errors can be found:

[14-10-31 21:36:59.406 TEMPLATESTORE 0030041 NTE] Request from XXX.XXX.XXX.XXX for StoreID #YYY, VendorID #ZZZZZZZ, httpindexphp= [14-10-31 21:36:59.406 TEMPLATESTORE 0030041 NTE] Path::Path [14-10-31 21:36:59.406 BMAPI 0030041 NTE] SCREEN: DEFAULT PAGE [14-10-31 21:36:59.410 TEMPLATESTORE 0030041 NTE] GetCurrencyIDforStore_API StoreID #YYY [14-10-31 18:28:06.290 TEMPLATESTORE 0029663 NTE] STP::~sendrecv execution timeout 0.013129949569702 [14-10-31 18:28:06.290 TEMPLATESTORE 0029663 NTE] CACHE ERROR: HY000 = file is encrypted or is not a database

Cause

Online Store with requested ID is not in the cache. It should be verified by Logging to the PBA-E online store server and browsing the following folder:

/usr/local/bm/templatestore/cache/ 

Store cache could be lost during Online Store server redeployment or different system failure.

Resolution

It is required to login to PBA-E Control Panel under Reseller ZZZZZZZ and synchronize Online Store YYY:

Home - Products - Online Store - Synchronize Now.

Make sure that required store is selected for editing first:

Home - Products - Online Store - Switch Store - "Selected for Editing" = Yes

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