Article ID: 122380, created on Jul 16, 2014, last review on Oct 30, 2014

  • Applies to:
  • Business Automation 5.4


Customer is trying to place upgrade order in Customers Control Panel (CCP) to switch from one conflicting resource to another.

The system does not allow to place order and throws the error like:

You cannot order Resource #100181 Linux VPS 512 Mb now: it conflicts with Resource #100180 Linux VPS 256 Mb which is already installed/ordered in Your Subscription #1039034. 


The error is thrown because switching between two conflicting resources requires to make two operations:

1) Downgrade 1st resource

2) Upgrade 2nd resource

However placing orders for two operations from CCP is not yet supported. This issue has been assigned an internal ID PBA-34927 and will be fixed in one of the next PBA-E updates.


There are two ways to switch between resources:

1) From Provider's Control Panel:

  • Navigate to: Home > Support Manager > Subscriptions > Subscription_ID > Resources >
  • Select required resource
  • Press button "Switch Resource"
  • Select another resource and place order

2) From Customers Control Panel:

  • Make sure that it is possible to downgrade 1st resource from CCP, by setting its quantity to 0 (Please refer to KB: if necessary)
  • Place Downgrade order for 1st resource
  • Place Upgrade Order for 2nd resource

Search Words

switch resource

resource conflict

resource upgrade

198398b282069eaf2d94a6af87dcb3ff caea8340e2d186a540518d08602aa065 210d017ddc3a076d22f0f865b1cf0730 92711db0799e8aefe8e51f12dace0496 e12cea1d47a3125d335d68e6d4e15e07

Email subscription for changes to this article
Save as PDF