Article ID: 122378, created on Jul 16, 2014, last review on Oct 6, 2014

  • Applies to:
  • Operations Automation 5.5
  • Business Automation 5.5

Symptoms

A Provider tries to perform searching for an account or subscription in:

Home > Operations > Customers Home > Operations > Subscriptions

However, the tab stops opening and the following error is displayed:

System Error
Data packet type error. Type: 6 Index: 1

In BM.log, the following error can be found:

ERROR: could not determine data type of parameter \$1; Error while preparing parameters") = NOTFOUND

or:

ExceptionResult: ODBC code #22021: ERROR: invalid byte sequence for encoding "UTF8": 0x9e; Error while executing the query

Cause

This issue is caused by an incorrect search form implementation. The form becomes broken when a user enters three letters or fewer in a search field like "Company name" or "Subscription Name".

The issue has been assigned the internal ID PBA-57638 and has been fixed starting from Parallels Business Automation - Enterprise (PBA-E) 5.5.7.

Resolution

The search field data is stored in special interface customization files that can be located on the PBA-E application host. For example:

/usr/local/bm/conf/wnd/BM/1.customization/Account_MyCustomersList.xml.
/usr/local/bm/conf/wnd/BM/1.customization/Subscription_SubscriptionMenuList.xml

In this example, 1 is the ID of the account/staff member who used the search form. "Account_MyCustomersList" refers to a "Customers" screen. "Subscription_SubscriptionMenuList" refers to a "Subscriptions" screen.

The content of the customized file may hold the keyword that was searched for:

<elements>   
    <table id="t1" *******,  CompanyName=rsi, *******>   
</elements>   

To work around the issue, delete customized XML files located in /usr/local/bm/conf/wnd/BM/_USERID_.customization/*.xml that hold three or fewer letters of the search input data. Note: In this example, USERID is the ID of the PBA-E user that the reseller logs in to the control panel as.

If after removing this file the error is still shown, log out of the control panel, clear the browser cache, and log in again.

To permanently fix this error, update PBA-E to 5.5.7.

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