Article ID: 121965, created on Jun 10, 2014, last review on Jun 10, 2014

  • Applies to:
  • Plesk Automation 11.5


An attempt to run yum check or yum update on the service node fails with the following error:

Error:  Multilib version problems found. This often means that the root
       cause is something else and multilib version checking is just
       pointing out that there is a problem.

The problem package is platform-runtime:

      Protected multilib versions: platform-runtime-1.0-089.el6.i686 != platform-runtime-1.0-38.rhel6.x86_64
 You could try using --skip-broken to work around the problem
** Found 1 pre-existing rpmdb problem(s), 'yum check' output follows:
platform-runtime-1.0-080.el6.i686 is a duplicate with platform-runtime-1.0-38.rhel6.x86_64


Another rhel platform-runtime installed on the server.


To fix the issue perform the following steps:

  1. Backup rpm database using the following commands:

    # mkdir /var/lib/rpm_backup
    # cp -a /var/lib/rpm/* /var/lib/rpm_backup/
  2. Removed rhel platform-runtime (use the package name from the yum error) from the server using the following command:

    # rpm -e platform-runtime-1.0-38.rhel6.x86_64 --nodeps --justdb

Search Words

Protected multilib versions platform-runtime

Error: Multilib version problems found


Multilib version problems found.

Protected multilib versions: platform-runtime-1.0-089.el6.i686

33a70544d00d562bbc5b17762c4ed2b3 e0aff7830fa22f92062ee4db78133079 caea8340e2d186a540518d08602aa065

Email subscription for changes to this article
Save as PDF