Article ID: 121488, created on May 7, 2014, last review on May 10, 2014

  • Applies to:
  • Plesk Automation 11.5

Symptoms

I bought and installed Parallels Premium Antivirus as per the following instructions in the documentation., but antivirus still does not work:

  • messages are not being blocked
  • there are no notifications about blocked messages

Cause

Appropriate email handlers are not activated, run the command below on the Postfix node to check:

# /usr/local/psa/admin/bin/mail_handlers_control --list
.---.---.-------.--------------------------------------.-----------------.------------------.---------------.
| E | P | prior |               address                |       name      |       type       |     queue     |
|---|---|-------|--------------------------------------|-----------------|------------------|---------------|
| X |   |    10 |                    admin@example.com |            spam |        recipient |  before-local |
|   |   |    20 |                    admin@example.com |           drweb |           sender | before-remote |
|   |   |    20 |                    admin@example.com |           drweb |        recipient |  before-queue |
'---'---'-------'--------------------------------------'-----------------'------------------'---------------'

As you can see only spam checker is activated (symbol "X" in first column).

Resolution

Turn off and then turn on antivirus again for the mail account in question.

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