Article ID: 121371, created on Apr 29, 2014, last review on Aug 30, 2014

  • Applies to:
  • Plesk Automation 11.5


I cannot open Websites tab under subscription, the following error is shownin GUI:

Smb_Exception: Domain not found
file: /usr/local/psa/admin/plib/Smb/Subscription/Domain.php
line: 57
code: 0

More detailed error can be found in /usr/local/psa/admin/logs/panel.log:

ERR (3)  [panel]: Domain not found:
0: Domain.php:57
        Smb_Subscription_Domain::getByExternalId(string '109')
1: auth.php:340
Smb_Exception: Domain not found
file: /usr/local/psa/admin/plib/Smb/Subscription/Domain.php
line: 57
code: 0
trace: #0 /usr/local/psa/admin/plib/auth.php(340): Smb_Subscription_Domain::getByExternalId('109')
#1 {main}


Domain has incorrect external_id value in psa database. It should be the same as webspace ID.


  1. Backup psa database:

    # mysqldump -uadmin -p`cat /etc/psa/.psa.shadow ` psa > /root/psa.`date +%F`
  2. Find webspace id in plesk database:

    # psql -Uplesk -h`hostname` plesk -c "select webspace_id,domain from plesk_webspaces where sub_id=109;
     webspace_id |     domain
             109 | example.tld

where sub_id is subscription ID from PPA.

  1. Find external_id for the domain in psa database:

    # mysql -uadmin -p`cat /etc/psa/.psa.shadow ` psa -e "select name,displayName,external_id from domains where name like '%example.tld%'"
    | name           | displayName    | external_id |
    | example.tld    | example.tld    | 502         |
  2. Update external_id, it should be the same as webspace_id (109 in our example):

    mysql -uadmin -p`cat /etc/psa/.psa.shadow ` psa -e "update domains set external_id=109 where name='example.tld'"

Search Words

ERROR: Smb_Exception: Domain not found (Domain.php:57)

Smb_Exception: Domain not found

33a70544d00d562bbc5b17762c4ed2b3 e0aff7830fa22f92062ee4db78133079 caea8340e2d186a540518d08602aa065

Email subscription for changes to this article
Save as PDF