Article ID: 121185, created on Apr 18, 2014, last review on May 9, 2014

  • Applies to:
  • Operations Automation 5.5


While following WAP deployment guide you may face the following error (section 3, step 22 on page 15):

$cnctString = 'Data Source=<WAP_DB_Address>;User ID=<User_ID>;Password=<Password>'

Set-MgmtSvcRelyingPartySettings -Target @('Admin', 'Tenant') -MetadataEndpoint https://WAP-APS:4486/wap/metadata.xml -ConnectionString $cnctString -DisableCertificateValidation 

Set-MgmtSvcRelyingPartySettings : Invalid URI: The format of the URI could not be determined.
At line:1 char:1
+ Set-MgmtSvcRelyingPartySettings -Target @('Admin', 'Tenant') -MetadataEndpoint ' ...
+ ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
+ CategoryInfo          : NotSpecified: (:) [Set-MgmtSvcRelyingPartySettings], UriFormatException
+ FullyQualifiedErrorId : System.UriFormatException,Microsoft.WindowsAzure.Config.PowerShell.Claims.SetRelyingPartySettings


Incorrect format of link in <wapPoaRedirectUrl> section of /usr/local/share/WAP/wap-config.xml


Before doing step 22, it is necessary to define the link <wapPoaRedirectUrl>, and it should be specified with http/https prefix, e.g. https://linmn.domain.tld; instead of just linmn.domain.tld

After correcting this, please restart WAP:

# service WAP restart

5b048d9bddf8048a00aba7e0bdadef37 caea8340e2d186a540518d08602aa065 5356b422f65bdad1c3e9edca5d74a1ae 2554725ed606193dd9bbce21365bed4e e12cea1d47a3125d335d68e6d4e15e07

Email subscription for changes to this article
Save as PDF