Article ID: 120970, created on Apr 9, 2014, last review on Aug 18, 2014

  • Applies to:
  • Operations Automation 5.5
  • Operations Automation 5.0

Symptoms

The task "Revoke permissions from public folder ..." for Exchange 2010 fails with the following error:

Public folder user "NT User:S-1-5-21-2712436344-3576784617-3866519510-156852" doesn't exist. A valid public folder user should be a mail-enabled user, mailbox, or distribution group.

Cause

It happens because the user that owns this permission has been already removed.

Resolution

Remove such permissions using the script 'CleanMissedPermissions.ps1' from this link:

  1. Get the root folder of the customer's organization where this error happens (you can find it in Provider Control Panel on the screen located at Services > E-mail > Organizations > <organization>).
  2. Place the script on the server with the Mailbox role.
  3. Run it in the following way:

    PS> .\CleanMissedPermissions.ps1 -RootFolder "\P000000XXX"
    

    where P000000XXX is the root folder of the customer's organization

  4. Restart the task.

Note: This may in some cases leave an object in inconsistent state. Please see KB#2247 for details on how to deal with out-of-sync objects.

Attachments

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