Article ID: 120851, created on Apr 2, 2014, last review on Aug 12, 2014

  • Applies to:
  • Plesk Automation 11.5

Symptoms

Transfer-list generating process fails with the following error:

TypeError: 'int' object is not subscriptable
[2014-04-01 17:58:17] [ERROR] | Unexpected error: ''int' object is not subscriptable', migration is aborted. See the traceback above for more information.
Context: fetch-target

Cause

Incorrect version of the Parallels Plesk Automation (PPA) Moving Tool is installed.

Resolution

Check Parallels Plesk Automation version:

# cat /usr/local/ppa/version
PPA 11.5.0 140220.12

Check the installed PPA Moving Tool version, run the following command:

# rpm -qi ppa-migrator-common

PPA Moving Tool version for PPA 11.1 has the 323083 release version:

# rpm -qi ppa-migrator-common
Name        : ppa-migrator-common          Relocations: /usr
Version     : 0.1                               Vendor: Parallels
Release     : 0.323083.192233009            Build Date: Thu 11 Jul 2013 12:30:24 PM EDT

Please check the release version of the PPA Moving Tool version installed on the server and if the Release matches 323083 or is low please reinstall Moving Tool using the instructions from the #120336 article.

Search Words

Unexpected error: ''int' object is not subscriptable'

Unexpected error: ''int' object is not subscriptable', migration is aborted

TypeError: 'int' object is not subscriptable

33a70544d00d562bbc5b17762c4ed2b3 e0aff7830fa22f92062ee4db78133079 caea8340e2d186a540518d08602aa065

Email subscription for changes to this article
Save as PDF