Article ID: 120560, created on Mar 15, 2014, last review on May 11, 2014

  • Applies to:
  • Operations Automation

Symptoms

While trying to delete an email alias for a Hosted Exchange mailbox from the Customer Control Panel (CCP), the following error occurs:

0 E-mail addresses were scheduled for deletion, 1 e-mail addresses can not be deleted

Cause

If the mailbox domain is protected in MessageLabs, the problem may be caused by a duplicate entry for this e-mail in the mlabs_protected_emails table in the Parallels Operations Automation (POA) database. This may have been caused by canceled/deleted tasks.

If this mailbox is somehow related to an APS package, the problem may be caused by APS-14658, which was fixed in POA 5.5.3. In this case, the following will be present in poa.debug.log:

 [txn:228020 SDK::UpdateMailRecipientsObserver::onUpdateMailRecipients] ExSystem: module_id:'Common', ex_type_id:'1',Message:'Internal error: Failed to remove APS link..', deprecated_codes = (0, 0), properties = { reason: 'Failed to remove APS link.', }

Resolution

Update POA to 5.5.3 or remove the duplicated entry in table mlabs_protected_emails:

Please note: it is strongly suggested that you create backups before performing manual database changes.

  1. Obtain the email_id:

    plesk=> SELECT * FROM mlabs_protected_emails where email like '%email@domain.tld%' ;
    
  2. Take the email ID of the last duplicate and remove the entry:

    plesk=> delete FROM mlabs_protected_emails where email_id = $ID;
    

Search Words

addresses can not be deleted

addresses were scheduled

Cannot delete email alias

exchange - cannot remove address from mailbox

5356b422f65bdad1c3e9edca5d74a1ae caea8340e2d186a540518d08602aa065 e12cea1d47a3125d335d68e6d4e15e07

Email subscription for changes to this article
Save as PDF