Article ID: 120336, created on Feb 26, 2014, last review on May 11, 2014

  • Applies to:
  • Plesk Automation

Symptoms

Error during upgrade of Parallels Plesk Automation (PPA) Migration Tools:

    [root@ppa ~]$ ./installer.sh --upgrade
    ppa-migrator-cbm-api-0.1-0.327499.338155520.noarch from installed has depsolving problems
      --> Missing Dependency: ppa-migrator-common = 0.1-0.327499.338155520 is needed by package ppa-migrator-cbm-api-0.1-0.327499.338155520.noarch (installed)
    Error: Missing Dependency: ppa-migrator-common = 0.1-0.327499.338155520 is needed by package ppa-migrator-cbm-api-0.1-0.327499.338155520.noarch (installed)
     You could try using --skip-broken to work around the problem

or wrong version of Migration Tools was installed:

    [root@ppa ~]$ cat /usr/local/ppa/version
    PPA 11.5.0 140205.12
    [root@ppa ~]$ cat installer.sh | grep PPA_URL
    PPA_URL=http://autoinstall.plesk.com/PPA_11.1.0

Cause

Packages conflict exist in the system or wrong version of the Migration Tools was installed.

Resolution

Reinstall Parallels Plesk Automation (PPA) migration tools.

  1. Delete installed Migration Tools:

    [root@ppa ~]# yum remove ppa-migrator-common
    
  2. Download installation script for PPA 11.1 or PPA 11.5 versions on the PPA Management node.

  3. Add execution permission and run installation of PPA Migration Tools:

    [root@ppa ~]# chmod +x installer.sh
    [root@ppa ~]# ./installer.sh
    
  4. Run upgrade of PPA Migration Tools:

    [root@ppa ~]# ./installer.sh --upgrade
    

Search Words

ppa-migrator

failed to upgrade migration tools

Migration tools

reinstall ppa-migrator

e0aff7830fa22f92062ee4db78133079 caea8340e2d186a540518d08602aa065

Email subscription for changes to this article
Save as PDF