Article ID: 120102, created on Feb 13, 2014, last review on May 11, 2014

  • Applies to:
  • Plesk Automation 11.5

Symptoms

Login to FTP fails for all domains with error:

    Cannot log in, home directory inaccessible 

Cause

  1. The domain resolves to a different IP than the one that has been configured in Plesk.

  2. The FTP server configuration is broken.

  3. The FTP_ROOT_D path was set incorrectly in HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\PLESK\PSA Config\Config.

Resolution

  1. Make sure that domain (that you use for FTP) resolves correctly. You can use the following command:

    nslookup domain.tld
    

This command returns IP should, it should be the same as the one configured in PPA for the domain.

  1. Reconfigure domain FTP settings using command below:

    /usr/local/psa/bin/repair --reconfigure-ftp-site -webspace-name
    

If you need to reconfigure FTP settings for all domains on Service Node, use the following command:

    /usr/local/psa/bin/repair --reconfigure-ftp-sites -service_node service_node_ip

where service_node_ip is IP address of Service Node.

  1. Open Registry Editor on FTP server (Start > Run > regedit), navigate to HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\PLESK\PSA Config\Config, check the FTP_ROOT_D path and verify that it corresponds existing physical directory.

  2. Check physical path for FTP sites in IIS->Web sites->IP address->Basic settings->physical path should be the part of FTP_ROOT_D from previous step.

33a70544d00d562bbc5b17762c4ed2b3 e0aff7830fa22f92062ee4db78133079 caea8340e2d186a540518d08602aa065

Email subscription for changes to this article
Save as PDF