Search Engine: Elastic

Article ID: 120087, created on Feb 12, 2014, last review on Jul 26, 2017

  • Applies to:
  • Odin Business Automation Standard

Symptoms

I want to upgrade Operating System (OS) in a container with OBAS installed. The following error appears when I try to upgrade via PVA:

Error
Failed to get list of available updates.
Error:  Failed to retrieve a list of updates for the installed software. (Details)

Error Details
Can not update packages: ' vzpkg update -q -n -p 99' exec failed - Error: Missing Dependency: whois >= 4.6.26 is needed by package hspc-release-4.5-55.swsoft.i386 (installed)
Error: Missing Dependency: /usr/lib/perl5/site_perl/5.8.8/XML/SAX.pm is needed by package hspc-release-4.5-55.swsoft.i386 (installed)
Error: Missing Dependency: perl(IPC::ShareLite) is needed by package hspc-release-4.5-55.swsoft.i386 (installed)

Cause

The OS upgrade in OBAS container is not performed the usual way.

Resolution

Use the instructions from these KB articles for upgrading OS in a container with OBAS installed:

How to update the OS (minor) of a OBAS server

How to upgrade OS (major) of OBAS server or migrate OBAS to new container

400e18f6ede9f8be5575a475d2d6b0a6 caea8340e2d186a540518d08602aa065 0efe2234e2ce513f2186f26c68447702

Email subscription for changes to this article
Save as PDF