Article ID: 120015, created on Feb 7, 2014, last review on May 29, 2015

  • Applies to:
  • Odin Business Automation Standard 4.5

Symptoms

I cannot provision a subscription to OA through OBAS. An order remains in status "Pending". The following errors are shown in a problem report:

[2014/02/06 12:10:43] [DEBUG] [30517] [HSPC::MT::PA::Protocol::compose_request] Request to PA:
[2014/02/06 12:10:43] [DEBUG] [30517] [HSPC::MT::PA::Protocol::compose_request] <?xml version="1.0" encoding="UTF-8"?><methodCall><methodName>pem.getAccountInfo</methodName><params><param><value><struct><member><name>account_id</name><value><i4>1408</i4></value></member></struct></value></param></params></methodCall>
[2014/02/06 12:10:43] [DEBUG] [30517] [HSPC::MT::PA::Protocol::parse_response] Response from PA:
[2014/02/06 12:10:43] [DEBUG] [30517] [HSPC::MT::PA::Protocol::parse_response] $VAR1 = {
'error_message' => 'There is no such account #1408.',
'extype_id' => '10',
'status' => '-1',
'module_id' => 'AccountManagement',
'error_code' => '1006',
'properties' => {
'account_id' => '1408'

and

[2014/02/06 12:10:46] [DEBUG] [30517] [HSPC::MT::PA::Protocol::compose_request] Request to PA:
[2014/02/06 12:10:46] [DEBUG] [30517] [HSPC::MT::PA::Protocol::compose_request] <?xml version="1.0" encoding="UTF-8"?><methodCall><methodName>pem.activateSubscription</methodName><params><param><value><struct><member><name>service_template_id</name><value><i4>30</i4></value></member><member><name>txn_id</name><value><string>86453</string></value></member><member><name>account_id</name><value><i4>1409</i4></value></member></struct></value></param></params></methodCall>
[2014/02/06 12:10:46] [DEBUG] [30517] [HSPC::MT::PA::Protocol::parse_response] Response from PA:
[2014/02/06 12:10:46] [DEBUG] [30517] [HSPC::MT::PA::Protocol::parse_response] $VAR1 = {
'error_message' => 'APS resource for \'/aps/2/application/subscriptions\' with id \'13420\' hasn\'t been registered. Error code: 403.',
'extype_id' => '35',
'status' => '-1',
'module_id' => 'SaaS',
'properties' => {
'resURI' => '/aps/2/application/subscriptions',
'object_id' => '13420',
'error_code' => '403' 

Cause

Such behavior was classified as the software issue PBAS-29259 and was fixed in OBAS 4.5.2 release.

Resolution

Upgrade OBAS to the latest version.

Workaround for OBAS 4.3.4

Workaround for OBAS 4.3.4 is attached. Download the package on the OBAS node and install it using the following commands:

~# rpm -Ufv hspc-pa-4.3.4-47.swsoft.i386.rpm
~# hspc-upgrade-manager --finish

Note: the hotfix is valid for OBAS version 4.3.4 only.

Search Words

There is no such account

Error code: 403

624ca542e40215e6f1d39170d8e7ec75 caea8340e2d186a540518d08602aa065 400e18f6ede9f8be5575a475d2d6b0a6 70a5401e8b9354cd1d64d0346f2c4a3e

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