Article ID: 119736, created on Jan 21, 2014, last review on May 9, 2014

  • Applies to:
  • Plesk Automation 11.5

Symptoms

PPA upgrade fails with updating pleskd-5.5.2 on Service Node. It shows the following error:

    [LOGTEE]: ERROR [HCL Process] ExSystem: module_id:'Common', ex_type_id:'1',Message:'Destination host 'domain.tld' (#2), IP '1.2.3.4' : Internal error: /bin/sh /bin/sh -c /usr/local/pem/sbin/pem-pkg-tool 'pleskd >= 5.5.2' failed with code 1 saying: STDOUT: '' STDERR '/usr/local/pem/sbin/pem-pkg-tool:21: DeprecationWarning: The popen2 module is deprecated.  Use the subprocess module.
    [LOGTEE]:   import popen2
    [LOGTEE]: Error: Package: pleskd-5.5.2.2-1.parallels.i386 (repo-id-9)
    [LOGTEE]:
    [LOGTEE]:            Requires: libxerces-c-3.0.so

Cause

Package "xerces-c" is excluded from yum installation.

Resolution

Login to Service Node and check /etc/yum.conf. Make sure that there is no excluded package as below:

    web01domain.tld:~# cat /etc/yum.conf |grep exclude
    exclude=xerces-c

Disable this record:

    web01domain.tld:~# cat /etc/yum.conf |grep exclude
    #exclude=xerces-c

Start PPA upgrade again.

Search Words

Failed to ping host

Failed to ping host

33a70544d00d562bbc5b17762c4ed2b3 e0aff7830fa22f92062ee4db78133079 caea8340e2d186a540518d08602aa065

Email subscription for changes to this article
Save as PDF