Article ID: 119734, created on Jan 21, 2014, last review on May 17, 2016

  • Applies to:
  • Plesk Automation 11.1
  • Plesk Automation 11.5

Symptoms

Either of the following symptoms occur after an unsuccessful Plesk Automation upgrade:

  1. A Plesk Automation upgrade to version 11.5 fails with the following error message:

    [ERROR]: Failed to ping host 'service_node.tld (4)': Failed to execute command: ['/usr/local/pem/bin/pleskd_ctl', '-f', '/usr/local/pem/etc/pleskd.props', 'ping', '4']
    
  2. Tasks fail with errors such as:

    [Plesk::AA::PEM_Current::check] {module_id="Common"; code="208"} Unauthenticated call to IDL:Plesk/pleskd:1.0::processHostOps. CORBA sessions must be authenticated using hub::acquire_own_cred
    

Cause

1) The Operations Automation (POA) Agent version (pleskd package) on the Service Node is different from the one installed on the Management Node.

2) Pem agent is not running.

Resolution

1) Please check the Pem agent version on the Management Node:

    # rpm -qa |grep pleskd
    pleskd-5.4.0.16-1.parallels

It is important that the Pleskd version on the Management Node corresponds to the Pleskd version on Service Nodes. If Pleskd has version 5.4 on the Management Node, it is necessary to downgrade Pleskd on Service Nodes to v5.4 too.

2) Check Service Nodes that are not pingable. On the Management Node, execute:

     psql -h`hostname` -U plesk -c"select host_id from hosts" -t -A -F ' '|while read id;do  echo PING SN: $id;/usr/local/pem/bin/pleskd_ctl -f /usr/local/pem/etc/pleskd.props ping $id;done

    PING SN: 7
    PING SN: 5
    PING SN: 15

Downgrading the Pleskd package on a Linux Service Nodes.

1) If the Pleskd package on the Management Node is version 5.4, log in to all Service Nodes that are not pingable and check their version of Pleskd.

    # rpm -qa |grep pleskd
    pleskd-5.4.0.16-1.parallels

If the version is different on Service Nodes (for example 5.5):

1) Log in to the Service Node and check where the pleskd configs are located:

    ps auxww | grep pem
    root     22224  0.0  4.6  62360 22896 pts/0    Sl   01:33   0:00 /usr/local/pem/sbin/pleskd --props-file /usr/local/pem/etc/pleskd.props --send-signal

2) Back up these configs on the Service Nodes:

    cp -Rp /usr/local/pem/etc /usr/local/pem/etcold

3) Download RPM's for the correct version. For example, for a Management Node on CentOS-5-x86_64, Service Nodes on CentOS 6:

    wget http://autoinstall.plesk.com/PPA_11.1.0/POA/CentOS-5-x86_64/os/RHEL/6/RPMS/ACE-5.6.1-3.pem.i686.rpm
    wget http://autoinstall.plesk.com/PPA_11.1.0/POA/CentOS-5-x86_64/os/RHEL/6/RPMS/ACE-TAO-1.6.1-3.pem.i686.rpm
    wget http://autoinstall.plesk.com/PPA_11.1.0/POA/CentOS-5-x86_64/os/RHEL/6/RPMS/xerces-c-2.5.0-6.pem.i386.rpm
    wget  http://autoinstall.plesk.com/PPA_11.1.0/updates/UPDATE_16/POA/CentOS-5-x86_64/os/RHEL/6/RPMS/pleskd-5.4.0.16-1.parallels.i386.rpm

Please Note: It is important to download the latest pleskd package for Plesk Automation 11.1, because some critical issues are fixed in it. Download the latest available pleskd package from Plesk Automation updates, using the link as above http://autoinstall.plesk.com/PPA_11.1.0/updates/UPDATE_**/POA/....

4) Downgrade and reinstall the packages on the Service Node as below:

    rpm -Uvh pleskd-5.4.0.16-1.parallels.i386.rpm ACE-TAO-1.6.1-3.pem.i686.rpm ACE-5.6.1-3.pem.i686.rpm xerces-c-2.5.0-6.pem.i386.rpm --nodeps --force
    rpm -e tao-2.0.5-1.3.parallels.el6.i686 --nodeps

5) Restart Pem Agent:

    /etc/init.d/pem restart
    Stopping pleskd:                                           [  OK  ]
    Starting pleskd:                                           [  OK  ]
  1. Perform the above on all the Service Nodes where Pem Agent needs to be downgraded.

To find out how to downgrade Pem Agent on a Windows Node, refer to this article:

Downgrade Pleskd package on Windows Node

As soon as the Pleskd version on the Management Node corresponds to the Pleskd version on Service Nodes, please launch the upgrade process again.

Search Words

-f

upgrade

Failed to execute command: ['/usr/local/pem/bin/pleskd_ctl

ERROR [addPackageMass] system exception

ppa upgrade error

Failed to execute command /usr/local/pem/bin/pleskd_ctl

Failed to ping host

IDL:omg.org/CORBA/COMM_FAILURE:1.0

CORBA sessions must be authenticated using hub::acquire_own_cred. 7:11088:22a0:12

ERROR [pingHost] ExSystem: module_id

Unauthenticated call to IDL:Plesk/pleskd:1.0::processHostOps. CORBA sessions must be authenticated using hub::acquire_own_cred. 7:11088:22a0:12

/usr/local/pem/etc/pleskd.props'

Failed to execute command: ['/usr/local/pem/bin/pleskd_ctl', '-f', '/usr/local/pem/etc/pleskd.props'

33a70544d00d562bbc5b17762c4ed2b3 e0aff7830fa22f92062ee4db78133079 c1ecc6010feff26cb42d1d14a7881dd6 caea8340e2d186a540518d08602aa065

Email subscription for changes to this article
Save as PDF