Article ID: 119710, created on Jan 17, 2014, last review on May 10, 2014

  • Applies to:
  • H-Sphere 3.6.2

Symptoms

Application could not be installed with the following errors:

Required PHP version greater than equal to 5.3.3 AND found version is : 5.2.17
Required PHP extension not found : zip

Cause

Softaculous is not configured properly.

Resolution

  1. Identify the path to the php bin file
    GoTo Softaculous Admin CP -> Settings -> Enduser PHP binary -> past "/hsphere/shared/php53/bin/php-cli"

  2. Edit the CHMOD Files to 0644 and CHMOD Directories to 0755 and click edit settings.

  3. If the issue with PHP Version is still present Define PHP Version.

    To define the PHP version in the Pre Install Hook please follow the steps:

Rename the pre_install.txt to pre_install.php in the Hooks folder ("/usr/local/softaculous/enduser/hooks/") (skip if file already exist)
Comment string $version = phpversion();
Add string $version = 5.3.27

function __pre_install(){   
    global $soft, $software, $globals;
    // Your Code to Identify the PHP version
    // E.g
    //$version = phpversion();
      $version = 5.3.27;
    define('php_version', $version);
}

For more information please use Softaculous Administration Guide.

Search Words

Required PHP extension not found : zip

zip

Required PHP version greater than equal to 5.3.3 AND found version is : 5.2.17

e5eac925e853cc7ef3f6055683c98fbb 6311ae17c1ee52b36e68aaf4ad066387 f213b9fa8759d57bee5d547445806fe7 2e39a5e5b1423cc126cf735bac076008

Email subscription for changes to this article
Save as PDF