Article ID: 119400, created on Dec 28, 2013, last review on May 10, 2014

  • Applies to:
  • Plesk Automation 11.5

Symptoms

After upgrade PHP to 5.3, my website shows PHP error:

    PHP Warning:  Directive 'register_globals' is deprecated in PHP 5.3 and greater in Unknown on line 0
    PHP Warning:  Directive 'register_long_arrays' is deprecated in PHP 5.3 and greater in Unknown on line 0

Cause

Deprecated php directives are enabled in php.ini

Resolution

  1. Open /etc/php.ini, domain php.ini file (/var/www/vhosts/system/domain.tld/etc/php.ini)

  2. Make sure that PHP.ini does not contain information about deprecated directives:

    register_globals = On
    register_long_arrays = On
    

If there are such lines, please delete or comment them as below:

    ;register_globals = On
    ;register_long_arrays = On

Search Words

large numbers of sites still down after upgrade BROKEN

33a70544d00d562bbc5b17762c4ed2b3 e0aff7830fa22f92062ee4db78133079 caea8340e2d186a540518d08602aa065

Email subscription for changes to this article
Save as PDF