Article ID: 119003, created on Dec 4, 2013, last review on Mar 30, 2015

  • Applies to:
  • H-Sphere 3.6.3
  • H-Sphere 3.5

Symptoms

The following error after system update

# service postgresql start
An old version of the database format was found.
You need to upgrade the data format before using PostgreSQL.

Cause

H-Sphere works correctly only with Postgres 7.x.

Resolution

  1. Install Postgresql rpm's that are shipped with H-Sphere:

    # cd /hsphere/pkg/
    # rpm -Uvh  postgresql*.rpm --force
    
  2. Start PSQL:

    # service postgresql start
    

Note: The issue may be avoided by yum exclude mechanism (see Force yum update Command To Exclude Certain Packages for details).

Search Words

An old version of the database format was found.

postgresql

You need to upgrade the data format before using PostgreSQL.

postgress dbase is not running and it’s failing to start

f51a27b0a406fdfb3fcda8033c7f914d 6311ae17c1ee52b36e68aaf4ad066387 f213b9fa8759d57bee5d547445806fe7 2e39a5e5b1423cc126cf735bac076008 6b908665c0d1eca5bdd0141a32fd712a

Email subscription for changes to this article
Save as PDF