Article ID: 118549, created on Nov 11, 2013, last review on Aug 12, 2014

  • Applies to:
  • Plesk Automation


I started migration, but it failed with the following error:

File "/usr/lib/python2.7/", line 181, in _read_gzip_header
raise IOError, 'Not a gzipped file'
IOError: Not a gzipped file
[ERROR] | Unexpected error: 'Not a gzipped file', migration is aborted. See the traceback above for more information.


The issue is caused by a bug in python "zipfile" library.


  1. Backup original file:

    cp /usr/lib/python2.7/ /usr/lib/python2.7/
  2. Download attached and apply it to your system:

    patch /usr/lib/python2.7/

NOTE: It might be needed to install "patch" utility: yum install patch

Search Words

Not a gzipped file

migration is aborted

e0aff7830fa22f92062ee4db78133079 caea8340e2d186a540518d08602aa065

Email subscription for changes to this article
Save as PDF