Article ID: 118474, created on Nov 6, 2013, last review on May 11, 2014

  • Applies to:
  • Business Automation

Symptoms

PBA installer fails to install a product (PBA Application, SDK, Database server, Online Store), the following error message is shown in the installer:

An error occurred when installing Parallels Business Automation (PBA) SDK.
No products match current OS installation

The /tmp/product_installer.log file on the server contains the entry like this:

Oct 24 2013 21:56:54 [:1617] DEBUG: Package bm-sdk-5.4.16-035 has 1 unresolved dependencies from packages list checked earlier (see log above).
Oct 24 2013 21:56:54 [:1617] DEBUG: <=====

Cause

The required RPM package is not installed on the server.

Resolution

Analyze the /tmp/product_installer.log on the server where you are trying to install a PBA product to find which RPM package is missing.

  1. Find the error message which says about unresolved dependencies, the example of such message is provided below:

    Oct 24 2013 21:56:54 [:1617] DEBUG: Package bm-sdk-5.4.16-035 has 1 unresolved dependencies from packages list checked earlier (see log above).
    
  2. Look for the similar error message about unresolved dependencies above in the same log file, e.g.:

    Oct 24 2013 21:56:54 [:1617] DEBUG: Package libetpan-devel-1.0-1.el6.pll has 1 unresolved dependencies from packages list checked earlier (see log above).
    Oct 24 2013 21:56:54 [:1617] DEBUG: -------> libxml2-devel
    

    In the case above the libxml2-devel package required by the libetpan-devel package is not installed.

  3. Install all found missing packages and retry to install a PBA product.

Search Words

install PBA

unresolved dependencies

bm-sdk

198398b282069eaf2d94a6af87dcb3ff caea8340e2d186a540518d08602aa065 e12cea1d47a3125d335d68e6d4e15e07

Email subscription for changes to this article
Save as PDF