Article ID: 118092, created on Oct 22, 2013, last review on May 5, 2014

  • Applies to:
  • Odin Business Automation Standard 4.3

Symptoms

When we log into the assigned customer's CP and select one of subscriptions, PBA-S crashes with an Application Error and we cannot take any further actions (neither in the CP nor in the PCC) because PBA-S loads itself to death.

The issue exists for customer account #CUS_ID, here is the log:

/var/log/hspc/hspc.log
---8<---
[2013/10/18 18:35:54] [DEBUG] [876] [HSPC::WebSystem::reinit_security] LOGIN:try to login to account # CUS_ID, result=HSPC::WebSecurity=HASH(0x202e027c)
...
[2013/10/18 18:35:54] [FATAL] [876] [Error::throw] error while running: reqiure HSPC::CP::Menu::Server; HSPC::CP::Menu::Server->dash_home(menu, ARRAY(0x204cf6b0), mode, );
called from package HSPC::CP::Menu at line 88
$@: Can't call method "timezone" on an undefined value at /usr/lib/perl5/site_perl/5.8.8/HSPC/WebSystem.pm line 701.
--->8---

Cause

The problem is likely caused by customer misconfiguration: link "Log in to CP" exists, but User account is missing.

Normally, the "Log in to CP" link should be hidden if there is no user account.

Resolution

Create User account:

Top > Account Director > Customer Manager > Customers > #CUS_ID > Users > Add New User

Search Words

Log in to CP

Can't call method "timezone" on an undefined value at

User is missing

400e18f6ede9f8be5575a475d2d6b0a6 caea8340e2d186a540518d08602aa065 807e9c1dc97aefd951b912a17e50c428 70a5401e8b9354cd1d64d0346f2c4a3e

Email subscription for changes to this article
Save as PDF