Article ID: 117826, created on Oct 9, 2013, last review on May 6, 2014

  • Applies to:
  • Business Automation

Symptoms

Credit card payment that should be automatically processed by the Dummy Payment System stuck in the Hold status, corresponding E-Transaction failed with the following error message:

Error2: Server Error. Could not process payment data. Please contact Provider.

The attempts to perform the authorization or charge of the credit card manually fail as well with the error messages:

Authorize failed. Reason: Error2: Server Error. Could not process payment data. Please contact Provider.

Capture declined. Reason: Error2: Server Error. Could not process payment data. Please contact Provider.

Cause

Private encryption key is not loaded to PBA.

Resolution

The Dummy Payment System is credit card based payment system, it requires that private encryption key is loaded to the system in order to decrypt credit card data.

Make sure that at least one pair of Encryption Keys is loaded to PBA according to the following instruction - Configuring Encryption Keys.

Search Words

payment stuck

automatically

Could not process payment data

hold

dummy payment

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