Article ID: 117713, created on Oct 4, 2013, last review on May 8, 2014

  • Applies to:
  • Operations Automation

Symptoms

Diskspace usage is not updating for subscriptions on the Linux Shared Hosting NG web cluster, subscriptions either show zero diskspace usage or the real diskspace usage on a NG web server does not match to the usage shown in the POA Control Panel.

Cause

Most likely custom quota management script cannot fetch quota properly and report it to POA.

Resolution

Log to the NG Director web sever and check the /var/log/poa.debug.log file - find quota checking method invocation, e.g.:

Oct  3 23:00:54 HEWSL02 : DBG [1:18937:b37f0b90:91000 33:69956:b6e26b90 pleskd]: [task:832472 bool<unnamed>::getfsquota_external] executing /usr/local/pem/etc/quota_ctl 10.10.10.1:/vol/NAS01 get user 100081
Oct  3 23:00:54 HEWSL02 : DBG [1:18937:b37f0b90:91000 33:69956:b6e26b90 pleskd]: [task:832472 bool<unnamed>::getfsquota_external] executing /usr/local/pem/etc/quota_ctl 10.10.10.1:/vol/NAS01 get user 100085

The entries above show that the custom quota management script /usr/local/pem/etc/quota_ctl is being used to get the current diskspace usage for NG hosting webspaces.

Try to execute the script manually for a NG user and check the result:

# /usr/local/pem/etc/quota_ctl 10.10.10.1:/vol/NAS01 get user 100081
0

Then compare the shown result with the value in the POA Control Panel, it they show the same diskspace quota then the reason of the problem in the custom quota management script and the Provider need to troubleshoot it.

Refer to the POA documentation for more details about Custom Quota Configuration Scripts in the NG Hosting module.

Search Words

diskspace

quota_ctl

NG Hosting

5356b422f65bdad1c3e9edca5d74a1ae caea8340e2d186a540518d08602aa065 e12cea1d47a3125d335d68e6d4e15e07

Email subscription for changes to this article
Save as PDF