Article ID: 117393, created on Sep 20, 2013, last review on Aug 15, 2014

  • Applies to:
  • Odin Business Automation Standard 4.3

Symptoms

We would like to disable PHP for our customers (on a Windows, Plesk 11.5 server) however still need it to be enabled to run Horde, Atmail and a custom script. In the Hosting Plan I disabled PHP support:

Top > Billing Director > Product Manager > Hosting Plans > Plesk 11.5 Windows Domain > Applications
--->8---
[] PHP support
---8<---

PHP cannot be disabled in Plesk platform settings:

Top > Billing Director > Product Manager > Hosting Plans > Plesk 11.5 Windows Domain > Plesk platform setup
--->8---
PHP version: PHP4|PHP5|PHP5.3|PHP5.4                   
PHP handler type: FastCGI application|FastCGI application|CGI application
---8<---

I left PHP5.3 and "FastCGI application" as handler type. Order domain subscription through store or PBAS (Top > Service Director > Plesk Manager > Domains > Add New Plesk Domain). Provisioning failed:

---8<---
2011    Error Failed    #110 Provision domain 'domain.tld' to...
        Process provisioning for document; Plesk Domain was added successfully (#3. But hosting setup failed: PHP version cannot be specified because PHP support is not enabled
        127.0.0.1
        20-Jul-2013, 10:37
Attention! See Problem # p2013-07-20_05-38-16 for details.
--->8---

Cause

Debug log indicates that PBAS sends a request to Parallels Plesk Panel 11.5 (123.123.123.123) that fails:

/var/log/hspc/hspc.log
---8<---
[2013/07/20 05:38:15] [DEBUG] [4099] [HSPC::MT::Plesk::PleskGate::__send_request_to_agent] Sending packet to 123.123.123.123 : 8443 : /enterprise/control/agent.php
[2013/07/20 05:38:15] [DEBUG] [4099] [HSPC::MT::Plesk::PleskGate::__send_request_to_agent] Final Packet=<packet version="1.6.5.0"><webspace>
...
<property><name>php</name><value>false</value></property>
...
<property><name>php-version</name><value>5.3</value></property>
...
[2013/07/20 05:38:16] [DEBUG] [4099] [HSPC::MT::Plesk::PleskGate::__send_request_to_agent] REPLY_DATA=<?xml version="1.0" encoding="UTF-8"?>
<packet version="1.6.5.0"><webspace><set><result><status>error</status><errcode>1019</errcode><errtext>PHP version cannot be specified because PHP support is not enabled</errtext><filter-id>3</filter-id><id>3</id></result></set></webspace></packet>
--->8---

Resolution

The problem has been fixed since PBA-S 4.3.4. Bug is PBAS-28851. Consider to upgrade PBA-S to the most recent version.

400e18f6ede9f8be5575a475d2d6b0a6 caea8340e2d186a540518d08602aa065 807e9c1dc97aefd951b912a17e50c428 70a5401e8b9354cd1d64d0346f2c4a3e

Email subscription for changes to this article
Save as PDF