Article ID: 117364, created on Sep 19, 2013, last review on Mar 30, 2015

  • Applies to:
  • Odin Business Automation Standard

Symptoms

1.Store is loading slow. Hosting Plans are not visible in the store.

2.Store us unavailable, the following error appears:

"Our store is temporarily closed.

We apologize for the inconvenience."

Cause

/var/log/hspc/hspc.log:
--->8---
[2013/09/18 02:30:30] [FATAL] [7790] [HSPC::Exc::Mysql::new] DBD::mysql::st execute failed: Got a packet bigger than 'max_allowed_packet' bytes at /usr/lib/perl5/site_perl/5.8.8/HSPC/WebDB.pm line 238.
---8<---

Resolution

Edit /etc/my.cnf (check if the db is remote in /etc/hspc/hspc.conf)

--->8---
[mysqld]
...
max_allowed_packet = 32M (value may be different, 32 should be enough)
---8<---

Restart MySQL.

Search Words

store is unavailable

Got a packet bigger than

Our store is temporarily closed.

max_allowed_packet

After Moving MySQL Database shop is not displayed correctly

We apologize for the inconvenience

400e18f6ede9f8be5575a475d2d6b0a6 caea8340e2d186a540518d08602aa065

Email subscription for changes to this article
Save as PDF