Article ID: 117321, created on Sep 17, 2013, last review on May 3, 2014

  • Applies to:
  • Business Automation 5.4

Symptoms

Provider cannot change the 'Charge for Subscription' option in the existing Service Plan in PBA Control Panel between the 'Before Subscription/Billing Period' and 'After Billing Period' values even if the plan does not have any active customer subscription, all subscriptions based on the plan are canceled or terminated.

When trying to change the 'Charge for Subscription' option the following error message is displayed:

You can't switch Recurring Type between pre-paid and post-paid because subscriptions are present.

Cause

In current PBA version billing type change is not possible in a Service Plan even if all exsiting subscriptions based on the plan are canceled/terminated.

Resolution

Create the new Service Plan with the desired billing type. Use the 'Clone Existing Plan' option to create new Service Plan with the same settings as in the original plan.

Search Words

You can't switch Recurring Type between pre-paid and post-paid because subscriptions are present

Charge for Subscription

Billing Period

198398b282069eaf2d94a6af87dcb3ff caea8340e2d186a540518d08602aa065 210d017ddc3a076d22f0f865b1cf0730 92711db0799e8aefe8e51f12dace0496 e12cea1d47a3125d335d68e6d4e15e07

Email subscription for changes to this article
Save as PDF