Article ID: 117272, created on Sep 16, 2013, last review on Aug 15, 2015

  • Applies to:
  • Odin Business Automation Standard 4.5

Symptoms

MaxMind GeoIP Country Database is not available (Top > Commerce Director > Anti-Fraud Manager > Anti-Fraud Plug-ins > IP Country)

GeoIP info: Error: no database available! 

The following error appears when try to upload a new MaxMind GeoIP Country Database:

Error: Cannot not initialize GeoIP database

in the log (/var/log/hspc/hspc.log):

[2013/07/12 09:19:58] [FATAL] [8790] [Error::throw] URI handler (HSPC::Fraud::Plugin::Setup->setup) error: Cannot open file for writing: No such file or directory at /usr/lib/perl5/site_perl/5.8.8/HSPC/Fraud/Plugin/IPCountry.pm line 149.

Cause

Database directory is missing on the OBAS node:

# ls -l /usr/share/GeoIP
ls: /usr/share/GeoIP: No such file or directory
#

Resolution

On the OBAS node create the missing directory and correct permissions:

# mkdir /usr/share/GeoIP
# chown apache:apache /usr/share/GeoIP

To upload the GeoIP Country Database: download the latest database from MaxMind, unzip the archive and upload it through:

Top > Commerce Director > Anti-Fraud Manager > Anti-Fraud Plug-ins > IP Country > Edit

Search Words

pay this document

no database available

cannot update geoip in fraud database

Error Opening file /usr/share/GeoIP/GeoIP.dat

GeoIP Country Database

400e18f6ede9f8be5575a475d2d6b0a6 caea8340e2d186a540518d08602aa065 70a5401e8b9354cd1d64d0346f2c4a3e 624ca542e40215e6f1d39170d8e7ec75

Email subscription for changes to this article
Save as PDF