Article ID: 117269, created on Sep 16, 2013, last review on Aug 30, 2016

  • Applies to:
  • Odin Business Automation Standard 4.5

Symptoms

A Plesk node is shown with Updating status on the Plesk Manager page:

Top > Service Director > Plesk Manager > Nodes

How can I make its status Available?

Cause

Odin Business Automation Standard (OBAS) detects when the Plesk node is upgraded and executes tasks on the OBAS side if required. For example:

  • Upgrade Plesk Control Panel from 9.x to 10.x
  • Upgrade Plesk Control Panel from 10.4 to 11.x

The Updating status indicates that the upgrade is not finished or that the corresponding tasks have failed.

The status of the task is shown in the Action Log (Top > Configuration Director > Logging and Errors > Action Log). The task may fail for any of the following reasons:

  1. There are unresolved conflicts for a Plesk client or a Plesk domain on this node. The following notification is shown in the Action Log (Top > Configuration Director > Logging and Errors > Action Log):

    Plesk Transport; Node #ID. Update domains... Errors detected during update process.
    
  2. The Plesk node has already been upgraded to the latest version manually (not through OBAS). The following notification is shown in the OBAS Debug log (/var/log/hspc/hspc.log):

    Strange: client #ID have type "customer" already. Manually converted in wizard on Plesk? 
    

    or

    Strange: client #ID have type "reseller" already. Converted already, or manually in wizard on Plesk?
    

Resolution

  1. Resolve all conflicts for this Plesk node:

    Top > Migration Director > Conflicts Resolver > Plesk Domains
    Top > Migration Director > Conflicts Resolver > Plesk Clients

    Execute the upgrade task for the Plesk node:

    Top > Service Director > Plesk Manager > Nodes > #PLESK_NODE_ID "Plesk node" > Reschedule Plesk upgrade

  2. Since resolving this issue requires complex manipulation of the database, it is recommended that you contact Odin Technical Support for assistance.

Important: Remember to run periodic tasks on updating statistics for Plesk after upgrading it:

PCC > Top > Configuration Director > Logging and Errors > Action Log > Tasks Queue

Update Plesk nodes stats info (click the task > 'Run now')
Plesk cache update (click the task > 'Run now')

Additional Information

Provisioning of Plesk subscription fails: "PleskAPIInvalidSecretKeyException : Invalid secret key usage"

Valid Plesk node has status "Not available" in OBAS

Search Words

Errors detected during update process

upgrade

Plesk node was upgraded

Manually converted in wizard on Plesk

Updating

Upgrading status

Converted already, or manually in wizard on Plesk

plesk node is "unregistered" or "upgrading"

Upgrading

Parallels does not generate an order

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