Article ID: 117086, created on Sep 4, 2013, last review on Sep 16, 2014

  • Applies to:
  • Operations Automation 5.4
  • Business Automation 5.5
  • Business Automation 5.4

Symptoms

An attempt to switch from Parallels Operations Automation (POA) to Parallels Business Automation (PBA), access the "Account" tab in the Customer Control Panel, or use any billing-related link for a particular account causes an error:

Fatal error An unforeseen error occurred. Please contact support@provider.com.
Error ID: <date_in_unix_format>

or

Billing is not available right now 

Also, the PBA login page may be shown.

Meanwhile, access for other accounts works fine.

On the PBA application server in the www.log file (located by default in the /usr/local/bm/log folder on Linux or the C:\Program Files\Parallels\PBA\log folder on Windows), the following error appears:

[13-08-07 17:27:55.905 UIWorker    RQ100985 WRN] Login or Password is incorrect.

Cause

There is a login/password discrepancy between POA and Parallels Business Automation - Enterprise (PBA-E) for the staff member used to log into the Provider Control Panel or Customer Control Panel.

Resolution

  1. If the login names are different in POA and PBA, update the user's login name in PBA with the UserUpdate_API API method call to match the login name in POA. Refer to the PBA-E Public API Reference for details.

  2. Reset the password for the staff member in POA or PBA to create matching passwords in both systems.

    To reset the password for a staff member in POA:

    For a client's staff member:

    Operations Director > Customer Manager > Customers > [select Account] > General > Staff members > [select staff member], click the 'Edit' button.

    For a provider's staff member:

    Configuration Director > Security Manager > Users > Staff Members > [select staff member], click the 'Edit' button.

    To reset the password for a staff member in PBA:

    For a client's staff member:

    Operation Director > Account Manager > Customers > [select Account] > Users > [select staff member], click the 'Change Password' button.

    For a provider's staff member:

    Configuration Director > Security Manager > Users > [select staff member], click the 'Change Password' button.

  3. It is also possible that the created user has a trailing space in its username in PBA-E, but this has been trimmed from the username in POA. In this case, an update to the PBA-E database is required. Please contact the Parallels Support Team to make this update.

Search Words

Billing tab showing blank

Error when trying to view Registred domains

java.lang.IllegalArgumentException: Illegal cookie name

"java.lang.IllegalArgumentException: Illegal cookie name".

An unforeseen error occurred

Fatal error An unforeseen error occurred.

致命的なエラー 予期しないエラーが発生しました。moriya@top-ad.co.jp までお問い合わせ下さい

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