Article ID: 117082, created on Sep 3, 2013, last review on Sep 13, 2014

  • Applies to:
  • Business Automation

Symptoms

PayPal refund or other transaction perfomed in direct mode fails with the following error message:

HTTP operation failed with error code 35

The error message is displayed in the e-transactions log in PBA Provider Control Panel. Also, the error message may be found in the system log file PAYPAL.log on the PBA Management Node.

Cause

SSL API certificates are configured incorrectly in the PayPal payment plug-in settins in PBA.

Note: even if Paypal is configured to work in redirect mode, refund is still being performed in direct mode.

Resolution

  1. Verify that PayPal certificate and key are correct using the commands like these on the PBA Management Node:

    openssl x509 -noout -text -in cert.pem    
    openssl rsa -noout -text -in key.pem
    

    Replace cert.pem and key.pem in the command above with the actual names of SSL certificate and private key.

  2. Verify that the full path to the certificate files in the PayPal payment plug-in settings is correct:

    • Log into PBA Provider Control Panel
    • Go to Configuration Director > E-Commerce Settings > Processing Centers > PayPal Processing Center
    • Make sure that the following parameters are correct:
      • API cert location
      • API key location

Refer to the PayPal Plug-in Configuration Guide for more details.

198398b282069eaf2d94a6af87dcb3ff caea8340e2d186a540518d08602aa065 e12cea1d47a3125d335d68e6d4e15e07

Email subscription for changes to this article
Save as PDF