Article ID: 116932, created on Aug 26, 2013, last review on Aug 12, 2014

  • Applies to:
  • Operations Automation 5.4

Symptoms

When a customer executes the "adsync run" command on the CDI (Customer Directory Integration) Agent server in their on-premise AD environment, it fails with an error message like that provided below:

Error. Server was unable to process request. ---> WebException: The remote name could not be resolved: 'open-api.host.local'

Cause

When the adsync command runs, the CDI Web Service on the Web Service Node tries to connect to the POA OpenAPI endpoint and fails because the API URL is configured incorrectly: web service cannot resolve the hostname of the POA Management Node.

Refer to the following diagram for more information about the CDI infrastructure:

Your text to link here...

The Open API URL in the AD Sync Web Service should be configured exactly as it is shown in POA Provider Control Panel at System Director > Public API Manager > Access Point, e.g. http://10.39.84.14:8440/RPC2, where 10.39.84.14 is IP address of the POA Management Node.

Resolution

Use one of the following methods to resolve the problem.

Resolution #1. Add the domain that the CDI Web Service tries to connect to into the hosts file on the Web Service Node to point to the POA OpenAPI access point stated in the POA Provider Control Panel at System Director > Public API Manager > Access Point. For example:

10.39.84.14 open-api.host.local

Resolution #2. Reinstall the CDI Web Service on the Web Service Node using instructions from the CDI Deployment Guide: Installing AD Sync Web Service. Use the correct Open API URL when installing web service.

Search Words

ADSync

The remote name could not be resolved

CDI Web Service

Server was unable to process request

Web Service Node

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