Article ID: 116753, created on Aug 13, 2013, last review on Jun 16, 2016

  • Applies to:
  • Plesk Automation 11.5

Symptoms

Cannot enable mail service for domain. The checkbox Activate mail service on domain is greyed out.

Cause

For some reason incorrect status was set up for the mail service on the domain in PSA database.

Resolution

  1. Create backup of PSA database.

  2. Login to PSA database:

    # plesk db
    
  3. Find domain with disabled mail service:

    mysql> select * from DomainServices where type='mail' and dom_id=(select id from domains where name='example.com');
        +-----+--------+------+--------+---------------+----------------+
        | id  | dom_id | type | status | parameters_id | ipCollectionId |
        +-----+--------+------+--------+---------------+----------------+
        | 167 |     61 | mail |      2 |           229 |            167 |
        +-----+--------+------+--------+---------------+----------------+
        1 row in set (0.00 sec)
    

    where example.com is a webspace name.

  4. Update the parameter of domain's mail service, having changed the status to 0:

    mysql> update DomainServices set status=0 where type='mail' and id=167;
    Query OK, 1 row affected (0.00 sec)
    
  5. Go to Customer Control Panel > Mail > Change settings and clear the checkbox Activate mail service on domain. Click OK.

  6. Go to Customer Control Panel > Mail > Change settings and tick the checkbox Activate mail service on domain. Click OK.

Search Words

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