Article ID: 116594, created on Jul 31, 2013, last review on May 11, 2014

  • Applies to:
  • Operations Automation


A customer installed the DotNetNuke 7.0.6 APS application into their PA subscription. When they log into the DotNetNuke admin interface and try to add new or existing module the following happens (depending on IIS website security settings):

  • Popup window with prompt to enter login credentials appears endlessly


  • Nothing happens, admin user is just being returned to the current page

The problem affects also standalone installation of the DotNetNuke application (installed not via APS application).


Adjust the web.config file of the IIS website where the DotNetNuke application is installed to resolve the issue:

  1. Backup the web.config file of the affected website on the corresponding IIS server
  2. Open the web.config file in editor
  3. Find the <system.webServer> section and add the runAllManagedModulesForAllRequests="true" attribute to the <modules> tag like in the example below:

      <modules runAllManagedModulesForAllRequests="true">
  4. Refresh the admin interface of the DotNetNuke application in browser or re-log into the application


The problem is caused by the issue in the DotNetNuke application itself.

Search Words

on attempt to load dotnetnuke module password is required

'Add Module' does not work in the DotNetNuke APS application

caea8340e2d186a540518d08602aa065 5356b422f65bdad1c3e9edca5d74a1ae e12cea1d47a3125d335d68e6d4e15e07

Email subscription for changes to this article
Save as PDF