Article ID: 116308, created on Jun 20, 2013, last review on Aug 12, 2014

  • Applies to:
  • Operations Automation 5.x

Symptoms

The precheck tool fails with the following exception:

"RPMs check failed on hosts below. perl-NetAddr-IP should be installed on the hosts with spamassassin."

Or, upgrading to POA 5.5 fails with this exception:

"perl(NetAddr::IP) >= 4.000 is needed by perl-Mail-SpamAssassin-%version%.pem.i386"

Cause

There is no "perl(NetAddr::IP)" RPM installed on the qmail node.

Resolution

  1. Download "perl-NetAddr-IP" on the qmail host where the problem occurred:
    wget https://kb.odin.com/Attachments/25243/Attachments/perl-NetAddr-IP-4.027-1.i386.rpm
  2. Run the following command:
    rpm -Uhv perl-NetAddr-IP-4.027-1.i386.rpm to install rpm.

You can run the following one-liner to make the changes:
rpm -Uhv https://kb.odin.com/Attachments/25243/Attachments/perl-NetAddr-IP-4.027-1.i386.rpm

Attachments

caea8340e2d186a540518d08602aa065 5356b422f65bdad1c3e9edca5d74a1ae 2554725ed606193dd9bbce21365bed4e e12cea1d47a3125d335d68e6d4e15e07

Email subscription for changes to this article
Save as PDF