Article ID: 115988, created on Apr 19, 2013, last review on May 11, 2014

  • Applies to:
  • Operations Automation 5.4

Symptoms

When deploying and running a new UI Server on VPS for POA 5.4 builds earlier than 5.4.10, pemui service cannot start and fails with the error:

# cat /var/log/catalina.out
/usr/local/apache-tomcat-5.5.25/bin/catalina.sh: line 273: /usr/java/jdk1.6.0_26/bin/java: No such file or directory


In this case, JDK with a version newer than 1.6.0_26 is installed in the system :

# rpm -q jdk
jdk-1.6.0_39-fcs


Cause

In 5.4.10, JDK was updated to 1.6.0_39, and now, this JDK version is accessible from download.pa.parallels.com.

When installing pemui, the latest JDK version will be grabbed and installed from download.pa.parallels.com by yum.

The problem arises because the package jakarta-tomcat-5.5.25-9 is rigidly tied to the package in JDK version 1.6.0_26 (in the start script), and thus it fails with the new version of JDK.


Resolution

In the file /usr/local/pem/etc/ui/pemui change the line:

export JAVA_HOME=/usr/java/jdk1.6.0_26

to the following:

export JAVA_HOME=/usr/java/jdk1.6.0_39

and then start pemui service:

# /etc/init.d/pemui start



 

ac82ce33439a9c1feec4ff4f2f638899 caea8340e2d186a540518d08602aa065 5356b422f65bdad1c3e9edca5d74a1ae 2554725ed606193dd9bbce21365bed4e e12cea1d47a3125d335d68e6d4e15e07

Email subscription for changes to this article
Save as PDF