Article ID: 115939, created on Apr 12, 2013, last review on Mar 23, 2016

  • Applies to:
  • Operations Automation

Symptoms


BackupAgent APS provisioning task fails in POA with the following diagnostics:
PHP Fatal error: SOAP-ERROR: Parsing WSDL: Couldn't load from 'http://10.1.1.10/BackupAgentServices/BAWebService.asmx?WSDL' :
failed to load external entity "http://10.1.1.10/BackupAgentServices/BAWebService.asmx?WSDL"
in /usr/local/pem/APS/instances/149/scripts/baws/soapclient.php on line 55
PHP Fatal error: Class 'Product_Exception_Offline' not found in /usr/local/pem/APS/instances/149/scripts/baws/soapclient.php on line 153

It may be any kind of provisioning tasks - install new instance of the BackupAgent APS application, re-configure installed instance, create new or manage existing users with BackupAgent service.

Cause


Provisioning scripts from the BackupAgent APS application cannot connect to the BackupAgent web service due to the network problems or problem with the BackupAgent web service itself.

Resolution


Make sure that provisioning scripts from the BackupAgent APS application cannot connect to the BackupAgent web service.

1. Make sure that BackupAgent web service is up and running:

  • Log into BackupAgent server using RDP
  • Run the BackupAgent Management Console and make sure that you may log in
  • If you cannot log into the BackupAgent Management Console check if the corresponding IIS website is up ad running, try to restart website and/or IIS itself

The default path to the BackupAgent Management Console is "C:\Program Files\BackupAgent Provider\BackupAgent ManagementConsole.url"

2. Make sure that correct connection parameters are configured in POA BackupAgent resource type:

  • Log into POA Provider Control Panel
  • Go to Service Director > Application Manager > Applications
  • Click on the BackupAgent application
  • Switch to the Resource Types tab
  • Click on the resource based on the Application resource class
  • Switch to the Activation Parameters > Global Settings tab
  • Verify the following parameters:
    • BA internal host - hostname or IP address of BackupAgent installation, used for provisioning access.
    • BA administrator login - BackupAgent admin user
    • BA administrator password - BackupAgent admin password
    • BA Management Console protocol - HTTP/HTTPS

3. Verify access from the Provisioning Gateway Host to the BackupAgent web service

  • Using the ID of the problem BackupAgent APS application instance (it is shown in the failed task properties and in POA Customer Control Panel) find the Provisioining Gateway Host which POA is using to perform operations for a particular application instance - use the Knowledgebase article #115876 to do that. Provisioning scripts mentioned in the failed POA task are being run on the found host.
  • Log into the found Provisioning Gateway Host (PGH) using SSH/RDP.
  • Make sure that connection may be established from the PGH to the BackupAgent web service, e.g. use the telnet utility: telnet <BA_internal_host> <BA_port> where <BA_internal_host> is the hostname or IP address of the BackupAgent server (it is shown in the failed task properties and in the BA internal host parameter in POA BackupAgent resource type), <BA_port> - 80 (HTTP) or 443 (HTTPS), it may be seen in the failed task properties and in the BA Management Console protocol parameter in POA BackupAgent resource type.

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