Article ID: 115428, created on Jan 18, 2013, last review on May 11, 2014

  • Applies to:
  • Operations Automation 5.5

Symptoms

Installation of a PPM package (autoresponder2 in this example) fails with an error like the following:

Installation of package autoresponder2 1.17 (id=<Package ID>) to host <Host Name> (id=<Host ID>) was failed. Reason: Destination host '<Host Name> (#<Host ID>), IP '<Host IP Address> : Native dependency processing failed; list of dependences: libvmime = 0.9.1-2.parallels. Please either install the packages
above, or application templates with them. Error: Missing or unsatisfied requirements: { libvmime (=0.9.1-2.parallels) } Candidates were: [ libvmime (0.9.2-0.1.20110626svn., i386) ].

Cause

  1. The PPM package has strict version dependence (=0.9.1-2.parallels).

  2. There are additional RPM package YUM repositories (non-POA) configured on the node that have a newer version of the package. As a result, YUM does not list the required package, but lists the newest one, and POA thinks that the package is not available.

Resolution

There are two options to fix the problem.

First option:

  1. Install the required RPM manually via YUM, specifying the package name with the version.

  2. Retry installation of the PPM package.

Second option:

  1. Disable the YUM repository containing the newer version of the package.

  2. Retry installation of the PPM package.

  3. Re-enable the YUM repository.

Search Words

Native dependency processing failed

Please either install the packages above, or application templates with them.

failed task

caea8340e2d186a540518d08602aa065 5356b422f65bdad1c3e9edca5d74a1ae 2554725ed606193dd9bbce21365bed4e 5b048d9bddf8048a00aba7e0bdadef37 e12cea1d47a3125d335d68e6d4e15e07

Email subscription for changes to this article
Save as PDF